Change font size
It is currently Mon Jul 16, 2018 7:39 pm


Post a new topicPost a reply Page 1 of 1   [ 5 posts ]
Author Message
 Post subject: Weird electrical issue?
PostPosted: Wed May 27, 2015 12:48 pm 
Cams + Headers

Joined: Mon Aug 18, 2014 6:02 pm
Posts: 65
Location: calgary AB
I've been having an intermitent weird electrical problem in my 760. Every once in a while, sometimes twice a week sometimes not for months. All my dash warning lights come on kinda half illuminated. As well as the button for the ac which glows blue will flash. If I turn off my lights the dash lights get dimmer but still there faintly.
I first thought alternator and tested right away but charging at 14.2 at idle. Battery with Car off was over 13 volts.
And unsure if this relates but sometimes when I flick my windshield wiper on the radio cuts out for a split second?
Thinking maybe over charging from the alternator possibly?

_________________
90 740tic


Top
 Profile  
 
 Post subject: Re: Weird electrical issue?
PostPosted: Wed May 27, 2015 12:51 pm 
Haha, I just built a W24 Octo-Turbo, now what?!

Joined: Wed Dec 21, 2005 8:03 pm
Posts: 2852
Location: T2C
Without thinking too hard I would suggest you have a bad ground somewhere...

_________________
Dale

'67 123GT
'67 122s
'99 AMG E55T


Top
 Profile  
 
 Post subject: Re: Weird electrical issue?
PostPosted: Wed May 27, 2015 2:25 pm 
Cams + Headers

Joined: Mon Aug 18, 2014 6:02 pm
Posts: 65
Location: calgary AB
I checked connections at the battery, as well as to and from the alternator all seemed good. Any major grounds to check?

_________________
90 740tic


Top
 Profile  
 
 Post subject: Re: Weird electrical issue?
PostPosted: Wed May 27, 2015 3:01 pm 
First volvo in outer space
User avatar

Joined: Fri Dec 14, 2007 1:46 pm
Posts: 1594
Location: East L.A.
rick-deckard wrote:
I checked connections at the battery, as well as to and from the alternator all seemed good. Any major grounds to check?


This covers it pretty well for a 7/9 series car. https://www.brickboard.com/FAQ/700-900/ ... sisGrounds

_________________
Jim

66 122S (Garage Queen)
89 244 (Hers)
90 745Ti (Mine)
89 744 (SOLD/Bought back for other daughter)
78 242GT (Project... LOL)
91 244 (Don't Ask!!)


Top
 Profile  
 
 Post subject: Re: Weird electrical issue?
PostPosted: Wed May 27, 2015 3:13 pm 
Cams + Headers

Joined: Mon Aug 18, 2014 6:02 pm
Posts: 65
Location: calgary AB
Oh perfect. Thanks. Gonna start checking all tonight

_________________
90 740tic


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 5 posts ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net